NetworkManager and libnl3 (SL7)

Synopsis: Moderate: NetworkManager and libnl3 security, bug fix
Advisory ID: SLSA-2017:2299-1
Issue Date: 2017-08-01
CVE Numbers: CVE-2017-0553

The libnl3 packages contain a convenience library that simplifies using
the Linux kernel’s Netlink sockets interface for network manipulation.

The following packages have been upgraded to a later upstream version:
NetworkManager (1.8.0), network-manager-applet (1.8.0).

Security Fix(es) in the libnl3 component:

* An integer overflow leading to a heap-buffer overflow was found in the
libnl library. An attacker could use this flaw to cause an application
compiled with libnl to crash or possibly execute arbitrary code in the
context of the user running such an application. (CVE-2017-0553)

SL7
x86_64
NetworkManager-1.8.0-9.el7.x86_64.rpm
NetworkManager-adsl-1.8.0-9.el7.x86_64.rpm
NetworkManager-bluetooth-1.8.0-9.el7.x86_64.rpm
NetworkManager-debuginfo-1.8.0-9.el7.i686.rpm
NetworkManager-debuginfo-1.8.0-9.el7.x86_64.rpm
NetworkManager-glib-1.8.0-9.el7.i686.rpm
NetworkManager-glib-1.8.0-9.el7.x86_64.rpm
NetworkManager-libnm-1.8.0-9.el7.i686.rpm
NetworkManager-libnm-1.8.0-9.el7.x86_64.rpm
NetworkManager-libreswan-1.2.4-2.el7.x86_64.rpm
NetworkManager-libreswan-debuginfo-1.2.4-2.el7.x86_64.rpm
NetworkManager-libreswan-gnome-1.2.4-2.el7.x86_64.rpm
NetworkManager-ppp-1.8.0-9.el7.x86_64.rpm
NetworkManager-team-1.8.0-9.el7.x86_64.rpm
NetworkManager-tui-1.8.0-9.el7.x86_64.rpm
NetworkManager-wifi-1.8.0-9.el7.x86_64.rpm
NetworkManager-wwan-1.8.0-9.el7.x86_64.rpm
libnl3-3.2.28-4.el7.i686.rpm
libnl3-3.2.28-4.el7.x86_64.rpm
libnl3-cli-3.2.28-4.el7.i686.rpm
libnl3-cli-3.2.28-4.el7.x86_64.rpm
libnl3-debuginfo-3.2.28-4.el7.i686.rpm
libnl3-debuginfo-3.2.28-4.el7.x86_64.rpm
libnm-gtk-1.8.0-3.el7.i686.rpm
libnm-gtk-1.8.0-3.el7.x86_64.rpm
libnma-1.8.0-3.el7.i686.rpm
libnma-1.8.0-3.el7.x86_64.rpm
network-manager-applet-debuginfo-1.8.0-3.el7.i686.rpm
network-manager-applet-debuginfo-1.8.0-3.el7.x86_64.rpm
nm-connection-editor-1.8.0-3.el7.x86_64.rpm
NetworkManager-glib-devel-1.8.0-9.el7.i686.rpm
NetworkManager-glib-devel-1.8.0-9.el7.x86_64.rpm
NetworkManager-libnm-devel-1.8.0-9.el7.i686.rpm
NetworkManager-libnm-devel-1.8.0-9.el7.x86_64.rpm
libnl3-devel-3.2.28-4.el7.i686.rpm
libnl3-devel-3.2.28-4.el7.x86_64.rpm
libnl3-doc-3.2.28-4.el7.x86_64.rpm
libnm-gtk-devel-1.8.0-3.el7.i686.rpm
libnm-gtk-devel-1.8.0-3.el7.x86_64.rpm
libnma-devel-1.8.0-3.el7.i686.rpm
libnma-devel-1.8.0-3.el7.x86_64.rpm
network-manager-applet-1.8.0-3.el7.x86_64.rpm
noarch
NetworkManager-config-server-1.8.0-9.el7.noarch.rpm
NetworkManager-dispatcher-routing-rules-1.8.0-9.el7.noarch.rpm

– Scientific Linux Development Team