Skip to content.

Scientific Linux

Sections
Personal tools
You are here: Home » Distributions » 6x » Building » Problem RPMs By Package

Problem RPMs By Package

RPMs that needed special attention during their build, listed by name
    • ekiga / opal
    • Problem: Ekiga wouldn't build
    • Solution: This was a case where opal needed a bug fix patch in order for ekiga to build. The opal-3.6.6-buildopts.patch was missing one line "#include " for it to work properly.
    • foomatic
    • Problem: Wouldn't build
    • Solution: Built it on a Fedora 13 based mock system that says it is el6.
      Not a real solution, but it got it built.
    • grub
    • Problem: Wouldn't build on x86_64
      Required /usr/lib/libc.a which is found in glibc-static.i686 but not in TUV x86_64 release.
    • Solution: Added glibc-static.i686 to SL6 x86_64.
      Reasoning: Since we are building glibc-static.i686 anyway, it is simply a matter of putting it into the list of i686 rpms that are put into x86_64.
    • guile
    • Problem: Wouldn't build
    • Solution: We edited the spec file and commented out it's final check.
    • hivex
    • Problem: Wouldn't build
    • Solution: Built it on a Fedora 13 based mock system that says it is el6.
      Not a real solution, but it got it built.
    • kdepim-runtime
    • Problem:Wouldn't build
    • Solution: Added patch required to build with the webkit (bz#660581)
      • mod_auth_kerb
      • Problem: Wouldn't build
      • Solution: We edited the spec file and changed "--with-krb5=/usr/kerberos" to "--with-krb5=/usr" because the krb location changed on SL6.
      • nss
      • Problem: Wouldn't build
      • Solution: We edited the spec file, removing several tests.
        Note: The first updated nss still had the same problem.
      • perl-CGI-Session
      • Problem: Wouldn't build
        Required perl-Time-HiRes and perl-CGI but these weren't listed on the BuildRequires.
      • Solution: Change mock file to include perl-Time-HiRes and perl-CGI for perl-CGI-Session
      • perl-GSSAPI
      • Problem: Wouldn't build
      • Solution: Built it on a Fedora 13 based mock system that says it is el6.
        Not a real solution, but it got it built.
      • perl-IPC-Run3
      • Problem: Wouldn't build
        Required perl-Time-HiRes but this wasn't listed on the BuildRequires.
      • Solution:Change mock file to include perl-Time-HiRes for perl-IPC-Run3
      • perl-Makefile-Parser
      • Problem: Wouldn't build
        Required perl-Time-HiRes but this wasn't listed on the BuildRequires.
      • Solution:Change mock file to include perl-Time-HiRes for perl-Makefile-Parser
      • perl-Sys-Virt
      • Problem: Wouldn't build
        Required perl-Time-HiRes but this wasn't listed on the BuildRequires.
        It also had the problem where it wouldn't build on our Koji server. The problem is because the mock area koji sets up has "user_host_resolve = False" and it needs to be "user_host_resolve = True"
      • Solution:Change mock file to include perl-Time-HiRes for perl-Sys-Virt, and it would then build on mock. We also build this on a pure mock enviroment, not going through koji.
      • perl-Test-Memory-Cycle
      • Problem: Wouldn't build
        Required perl-CGI but this wasn't listed on the BuildRequires.
      • Solution:Change mock file to include perl-CGI for perl-Test-Memory-Cycle
      • perl-Test-MockObject
      • Problem: Wouldn't build
      • Solution: Built it on a Fedora 13 based mock system that says it is el6.
        Not a real solution, but it got it built.
      • pilot-link
      • Problem: Wouldn't build
      • Solution: Changed spec file. When "autoreconf -is" is called this causes libtool to run from /usr/bin/libtool which is version 2.2.6b but the source ships its own libtool in pilot-link-0.12.4/libtool which is version 2.2.6 and called from the make files. This version mix does not work.
      • python-lxml
      • Problem: Wouldn't build
        Required python-devel but this wasn't listed on the BuildRequires.
      • Solution: Change mock file to include python-devel for python-lxml
      • python-nss / epydoc
      • Problem: python-nss wouldn't build
      • Solution:This was a case where epydoc needed a bug fix patch in order for python-nss to build. We put in the following patches from Fedora 13, but left the numbering the same as RHEL 6.
        Fix crash with newer docutils (#578920) - Lubomir Rintel
        Add texlive-dvips and texlive-latex requirements (#522249) - Matthias Saou
      • python-sqlalchemy
      • Problem: Wouldn't build
      • Solution: Built it on a RHEL6 Beta2 based mock system that says it is el6.
        Not a real solution, but it got it built.
      • rome
      • Problem: Wouldn't build
      • Solution: Changed spec file. SL 6 provides jdom-1.1.1 and not jdom-1.0 so we changed it to 1.1.1
      • ruby
      • Problem: Wouldn't build
      • Solution: Fixed a patch. We fixed the shellwords arguments building bug.
        Note: The first ruby update from TUV fixed this problem.
      • python-sqlalchemy
      • Problem:
      • Solution:
      • virt-top
      • Problem:Wouldn't build
        Required ocaml-camomile-data but this package isn't in the release.
      • Solution: We built ocaml-camomile-data from Fedora 13, and then put it in a special build repository so that mock could grab it when virt-top is built.
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
    • Problem:
    • Solution:
Created by dawson
Last modified 2011-03-02 02:58 PM
 

Powered by Plone

This site conforms to the following standards: