Skip to content.

Scientific Linux

Sections
Personal tools
You are here: Home » Distributions » 5x » SL 59 » Limitations

Limitations

Even Scientific Linux has limitations. This is a short list found in Scientific Linux 5

We strive for perfection. Any goal less than that is sortof silly. But we are also realistic. Not everything is going to be perfect. This page documents what we know is broken, or not living up to it's potential.

Freeradius2

The freeradius and freeradius2 packages share common files, and cannot be installed together on the same system.

postgresql84

postgresql84 and postgresql packages cannot be installed concurrently on the same system, with the exception that the postgresql-libs package can remain in place in parallel with postgresql84. The postgresql-libs package contains client-side library code to which existing applications may be linked. These libraries will still work with the newer server.

As 8.4.x also has on-disk data format differences from 8.1.x, it is not possible to upgrade an existing 8.1.x PostgreSQL database to 8.4.x merely by replacing the packages. Instead, first dump the contents of the existing database using the pg_dumpall command, then shut down the old server and remove the database files (under /var/lib/pgsql/data). Next, remove the old packages and install the new ones; start the new server; and finally restore the data from the pg_dumpall output.

while postgresql84 packages are provided, rebuilding other packages with this new version is not supported. If a package using postgresql-devel is to be rebuilt, a downgrade from postgresql84 to postgresql is necessary.

Virtulization

Xen based virtualization is fully supported. However, Xen-based virtualization requires a different version of the kernel to function. The KVM hypervisor can only be used with the regular (non-Xen) kernel.

While Xen and KVM may be installed on the same system, the default networking configuration for these are different. Users are strongly recommended to only install one hypervisor on a system.

Clusters and SELinux

SELinux in Enforcing mode is not supported with the Cluster Suite; Permissive or Disabled modes must be used.

Automounting

Removable storage devices (such as CDs and DVDs) do not automatically mount when you are logged in as root, or in a non graphical enviroment. If you are in a graphical enviroment, you will need to manually mount the device through the graphical file manager.

Alternatively, you can run the following command to mount a device to /media:

mount /dev/[device name] /media

X resolution

When running the bare-metal (non-Virtualized) kernel, the X server may not be able to retrieve EDID information from the monitor. When this occurs, the graphics driver will be unable to display resolutions highers than 800x600.

To work around this, add the following line to the ServerLayout section of /etc/X11/xorg.conf:

Option "Int10Backend" "x86emu"

Created by riehecky
Last modified 2013-02-05 09:44 AM
 

Powered by Plone

This site conforms to the following standards: