Skip to content.

Scientific Linux

Personal tools
You are here: Home » Distributions » 4x » Features » Limitations


Even Scientific Linux has limitations

We strive for perfection. Any goal less than that is sortof silly. But we are also realistic. Not everything is going to be perfect. This page documents what we know is broken, or not living up to it's potential.


This is a graphical package manager designed to install packages from CD.
Limitation : It does not work. It is only included to satisfy dependancies.


Designed to automatically query servers to determine if updates are needed.
Limitation : up2date is not supported in Scientific Linux. It is only included to satisfy dependancies. It may or may not work.

3ware 8xxx and 9xxx in same system

3ware 8xxx and 9xxx are both IDE cards, and the drivers for both in the installer.
Limitation :Grub can get confused about which "drives" are which if both of these cards are installed. You can either run grub manually before rebooting or use "noprobe" during the install and install only the 3ware driver for the card that you will be booting off of.

(SL 40 only - fixed in 4.1) openafs

Openafs is a distributed file system.
Limitation : We are including openafs, even though wee do not feel that it is enterprise production ready. It does work for the most part, but this version of openafs had not worked on all hardware.
64bit (x86_64) UP & SMP - works
32bit (i686) SMP - works
32bit (i686) UP - writes get stuck, not recommended

(SL 44 and above) ipw3945

Wireless driver, firmware and deamon for the Intel ipw3945 wireless chipset
Limitation : Does not work in the installer. Does not work on all laptops.

(Applies when updating from SL 4.0-4.6 to SL 4.7 and above)openmpi and lam

A bug in previous versions of openmpi and lam may prevent you from upgrading these packages. This same bug may cause yum to fail when upgrading all packages.
This bug manifests in the following error when attempting to upgrade openmpi or lam:
error: %preun(openmpi-[version]) scriptlet failed, exit status 2
Recommendation : You need to manually remove older versions of openmpi and lam first in order to avoid these errors. To do so, use the following rpm command:
rpm -qa | grep '^openmpi-\|^lam-' | xargs rpm -e --noscripts --allmatches

Created by dawson
Last modified 2008-09-03 09:21 AM

Powered by Plone

This site conforms to the following standards: